Dio 3.0发布,支持Flutter Web 和 Http/2.0

2019年11月4日23:08:31 发表评论 9 阅读
Flutter 一周前发布了1.9 版本,其中最大特性是将Flutter Web合入了主分支。而今天,Dio 也正式发布了3.0.0,该版本最大的特性是支持Flutter Web 和 Http/2.0。

升级提示:由于Dio 3.0需要支持Flutter Web,需要对代码进行较大的重构,所以并不能完全向下兼容,2.1版本用户可参考 3.0升级指南

支持Flutter Web

开发者只需要将Flutter升级到1.9或更新的dev版本,然后将Dio升级到最新的3.x即可支持Flutter Web即可。

Http/2.0支持

Http/2.0 有链接复用、头部压缩、二进制传输、服务端推送等重多特性。Dio 3.0版本后,官方提供了一个 dio_http2_adapter 插件(HttpClientAdapter)来支持Http/2.0。下面是官方示例:

  • 微信号:sqymail
  • 微信扫一扫欢迎加我为好
  • weinxin
  • 交流QQ群号:248249544
  • IntelliJ IDEA,Java 技术交流
  • weinxin

发表评论

您必须登录才能发表评论!